Eigentlichnichfürmir
Beiträge: 13
Registriert: Mi 31. Mär 2021, 15:31
Volla Phone mit: Ubuntu Touch

Nur TWRP installiert kein Volla OS

Hab mehrfach probiert ein fremdes Volla Phone von UT auf VOS zu bringen.
Der UBports Installer hängt dann ewig bzw. meldet einen Fehler:
"Error: unknown: TypeError: Cannot read property 'codename' of null".
Hat jemand das gleiche Problem gelöst?
TWRP 3.3.0 wurde allerdings erfolgreich installiert, mehr aber auch nicht.
Zuletzt geändert von Eigentlichnichfürmir am Di 6. Apr 2021, 18:09, insgesamt 3-mal geändert.
nift4
Beiträge: 38
Registriert: Mo 29. Mär 2021, 17:18
Wohnort: Deutschland
Volla Phone mit: Volla OS (Android 9)
sonstiges Handy/iPhone mit Android Version/iOS Version: Moto G5 mit LineageOS 18.1-fork Mint 3 und F(x)tec Pro¹ mit LineageOS 17.1
Kontaktdaten: Website

Re: Nur TWRP installiert kein Volla OS

Falls dein Host auf Windows läuft: Du brauchst Linux. Eigentlich sollte es auch auf Windows klappen, aber es geht zur Zeit nur mit Linux (evtl. macOS).
Hi :)
Ich bastel an Android Boot Manager, LineageOS und anderen Projekten.
- nift4
Eigentlichnichfürmir
Beiträge: 13
Registriert: Mi 31. Mär 2021, 15:31
Volla Phone mit: Ubuntu Touch

Re: Nur TWRP installiert kein Volla OS

Hatte ich vergessen zu schreiben:
OS Mint 20.3 64bit
Yaqwe
Beiträge: 5
Registriert: So 25. Jul 2021, 18:09
Volla Phone mit: Volla OS (Android 10)

Re: Nur TWRP installiert kein Volla OS

Hi,

ähnlich ist es bei mir.
Allerdings ist mir der Ubuntu Rechner während des Flashens abgestürzt, TWPR ist installiert. Das Gerät wird unter Ubuntu Linux 20.04.2 als
"k63v2 64 bsp" angezeigt und nicht eingehängt.
Wenn ich UBports starte, wird das Volla Phone nicht erkannt und wenn man manuell weiter machen möchte kommt die Meldung " Connection to device lost"

Ich habe es dann auch noch unter Windows versucht, komme damit aber auch nicht weiter.
Error: plugin wait(): Error: {"message":"{\"error\":{\"code\":126,\"cmd\":\"C:\\\\Users\\\\USER\\\\AppData\\\\Local\\\\Temp\\\\1raG3Aut6N5DTMPVp2eiGFFUdbP\\\\resources\\\\app.asar.unpacked\\\\node_modules\\\\android-tools-bin\\\\dist\\\\win32\\\\x86\\\\adb.exe -P 5037 shell getprop ro.product.device\"},\"stderr\":\"error: exec '/system/bin/sh' failed: No such file or directory\"}","name":"adb"}

Bevor ich noch mehr kaputt als heile mache, hoffe ich hier auf den Schubs in die richtige Richtung.
Yaqwe
Beiträge: 5
Registriert: So 25. Jul 2021, 18:09
Volla Phone mit: Volla OS (Android 10)

Re: Nur TWRP installiert kein Volla OS

Hi,

ich habe weiter versucht und bin ein bisschen weiter gekommen und bekomme neu Fehlermeldungen.

UBports meldet nach dem Ignore-drücken: "Error: unknown: TypeError: Cannot read property 'action__shell' of undefined"
Wenn man dann auf dem "zukünftigen" VollaOS Phone den ADB sideload weiter macht steht dann:

ADB Sideload Complete
Failed
Updating patition details...
Failed to mount '/data' (Invalid argument)
Failed to mount '/nvdata' (Invalid argument)

...done
Unable to mount storage
Failed to mount '/data' (invalid argument)

Full SELinux support is present.
Unable to mount /data/media/TWRP/.twrps
MTP Enabled
Starting ADB sideload feature

und da bleibt es dann auch...
Ist da noch was zu retten?
Yaqwe
Beiträge: 5
Registriert: So 25. Jul 2021, 18:09
Volla Phone mit: Volla OS (Android 10)

Re: Nur TWRP installiert kein Volla OS

Habe es jetzt hin bekommen. Im Großen und Ganzen wie in viewtopic.php?f=108&t=134 beschrieben.

Zurück zu „UBports Installer“